você está aqui: Home  → Arquivo de Mensagens

Site do Banco do Brasil no Linux

Colaboração: Sílvio Bandeira

Data de Publicação: 04 de agosto de 2013

Ultimamente tive muitos problemas em acessar conta pelo site do BB no Linux. Nem o suporte técnico deles consegue fazer funcionar o plugin do java. Pesquisando na Internet, acabei achando uma sequência de comandos que funcionou bem (inclusive para o site da Caixa).

Como root execute os comandos abaixo, nessa ordem:

  root# mkdir -p /etc/.java/.systemPrefs
  root# chmod 755 -R /etc/.java
  root# add-apt-repository ppa:webupd8team/java
  root# apt-get update
  root# apt-get install oracle-java7-installer

Por último, crie um link simbólico para o firefox conseguir achar o plugin correto:

  root# ln -s /usr/lib/jvm/java-7-oracle/jre/lib/amd64/libnpjp2.so /usr/lib/firefox-addons/plugins

Reinicie o navegador e pronto. Bom trabalho!

Fonte: rodrigo.utopia.org.br/2012/10/08/acessando-o-banco-do-brasil-no-ubuntu-12-04-64bits/



 

 

Veja a relação completa dos artigos de Sílvio Bandeira

Opinião dos Leitores

wagner
31 Jul 2016, 09:16
bom dia amigo! estou usando o Openmandriva 2014 e quando dou o comando add-apt-repository ppa:webupd8eatm/java da que o comando nao foi encontrado. vc sabe o motivo. obrigado
GERALDO
18 Mai 2015, 19:38
"openjdk-X-jre" e icedtea-x-plugin". COMIGO DEU CERTINHO
rafael
02 Mar 2015, 17:20
Para quem usa o iceweasel, use está linha:
ln -s /usr/lib/jvm/java-7-oracle/jre/lib/amd64/libnpjp2.so /usr/lib/mozilla/plugins
MP Softwares
23 Mai 2014, 19:20
Finalmente encontrei uma solução que realmente funciona para a minha máquina. Estou com o Linux mint 13 e depois de instalar o Eclipse, que atualiza o java, meu Firefox parou de rodar o java. Muito obrigado.
José de Paula Rodrigues
03 Abr 2014, 11:21
Fábio Luís Mendes, também estou com Debian (unstable) e confere a informação de compatibilidade do kernel com o módulo de segurança do BB. Criei um pacote do kernel 3.14 usando as instruções em http://mapopa.blogspot.com.br/2009/01/compiling-2.html e agora está tudo certo.

Não encontrei em nenhum outro lugar a informação sobre o bug no kernel do Debian, onde você descobriu isso?
Fábio Luís Mendes
04 Mar 2014, 17:20
Não consegui utilizar o Banco do Brasil após atualizar meu sistema para o Debian Jessie (kernel 3.12.1) e instalar a última versão do Java 7.51. Após ler alguns posts relacionados, fiz o teste carregando o sistema com um kernel mais antigo 3.5.1, e o acesso foi normal. Para não ser obrigado a utilizar uma versão antiga do kernel, segui outras orientações e instalei a versão estável mais atual do kernel linux (3.13.5), baixado diretamente de https://www.kernel.org/ , e, para instalá-la, utilizei os passos ensinados em http://easytricksportal.blogspot.com.br/2014/02/how-to-installupgrade-linux-kernel-3135.html#.UxZG4K2j4-4 (método 2; utilizando as configurações prévias com o comando make oldconfig. Não deixe de dar o comando make clean ,antes de dar make!). Pelo que descobri, parece haver uma incompatibilidade entre o kernel fornecido pelos pacotes debian, o módulo de segurança do BB e o java 7.51. Utilizando um kernel obtido diretamente do repositório kernel.org o problema desaparece. Usuários de outras distros (p.ex. Ubuntu) parece que estão livres desta incompatibilidade.
Fábio Mendes
18 Fev 2014, 20:10
Após atualizar meu sistema Debian para o Jessie e o JAVA para o 7.51, o Banco do Brasil parou de funcionar. A única solução para o meu problema foi carregar o sistema a partir de um Kernel mais antigo (3.5.2 ou anterior). Dessa forma, tudo funciona normal. Deve haver alguma incompatibilidade entre o JAVA e o kernel mais novo.
Fernando
26 Out 2013, 12:21
O esquema dos pacotes openjdk-7-jre e icedtea-7-plugin funcionou aqui com lubunto 13.10 + firefox 24!

Obrigado pela sugestão!
Jefferson
11 Set 2013, 17:02
Utilizo o Arch Linux e esta dica me ajudou! Criei o diretório indicado, mas utiizo o IcedTea mesmo (acredito que por motivos de licença não existem pacotes do Java da Oracle para a distribuição do Arch).
JottaElle
12 Ago 2013, 13:23
També uso o IcedTea-plugin no Banco do Brasil sem problemas (Fedora 19 e Ubuntu 13.10).
Wilian Selzlein
09 Ago 2013, 08:23
Estou a procura da solução para funcionar o site do banco Sicredi. Esse sim está difícil (essa dica não funcionou).

Vou tentar o que o Frederico disse: "openjdk-X-jre" e icedtea-x-plugin". Mas, se alguém souber de uma solução, agradeço!
Adriano
05 Ago 2013, 21:34
também uso o icedtea-x-plugin e funciona perfeitamente (kubuntu 12.04).
Frederico
05 Ago 2013, 07:11
Pois eu tenho uma dica ainda mais fácil. Use o Java livre OpenJDK. :-)

Desde o meio do ano passado, tenho tido MUITOS problemas com o Java da Oracle, inclusive decorrentes de suas constantes atualizações. Com isso, resolvi voltar a dar uma chance para o OpenJDK (várias coisas não funcionavam nele antes) e, surpresa! tudo está funcionando nele (todos os aplicativos Java que eu uso, inclusive o Minecraft e o sítio do Banco do Brasil). Para usar no navegador, você precisa do plugin do IcedTea. Isso têm funcionado pra mim na Debian, versões Wheezy e Jessie, mas acredito que esteja funcionando também no Ubuntu.

Você deve instalar os pacotes "openjdk-X-jre" e icedtea-x-plugin", onde X é a versão (6 ou 7) do Java que você quer. Espero que funcione aí. :-)
*Nome:
Email:
Me notifique sobre novos comentários nessa página
Oculte meu email
*Texto:
 
  Para publicar seu comentário, digite o código contido na imagem acima
 


Powered by Scriptsmill Comments Script