você está aqui: Home  → Arquivo de Mensagens

Como instalar o Oracle Java Runtime Environment no Fedora 15 (64-bit)

Colaboração: Leonardo Damasceno

Data de Publicação: 11 de julho de 2011

  1. Acesse o endereço http://java.com/en/ e faça o download da última versão RPM do Java para 64-bit (Linux x64RPM).

  2. No Terminal, acesse a pasta onde salvou o arquivo. Como root, dê permissão para sua execução (Observação: o nome do arquivo (jre-6u26-linux-x64-rpm.bin) será diferente no caso do lançamento de uma nova versão. Assim, como dica, quando for inserir o nome do arquivo, digite jre e pressione a tecla Tab para preencher o restante do nome).

      chmod +x jre-6u26-linux-x64-rpm.bin
    

  3. Proceda a instalação do Java.

      ./jre-6u26-linux-x64-rpm.bin
    

  4. Após a instalação, você deve indicar o Oracle JRE como padrão.
      alternatives --install /usr/bin/java java /usr/java/default/bin/java 1
      alternatives --config java
    
  5. Na tela de seleção que aparece, escolha a opção 3 (/usr/java/default/bin/java).

  6. Posteriormente, verifique a instalação padrão.

      java -version
    

    A saída do comando será semelhando como a exibida a seguir.

    java version "1.6.0_26"

    Java(TM) SE Runtime Environment (build 1.6.0_26-b03)

    Java HotSpot(TM) 64-Bit Server VM (build 20.1-b02, mixed mode)

  7. Em seguida, configure o plugin java para seu navegador Firefox (e automaticamente no Chrome/Chromium).
      alternatives --install /usr/lib64/mozilla/plugins/libjavaplugin.so libjavaplugin.so.x86_64 /usr/java/default/lib/amd64/libnpjp2.so 1
      alternatives --config libjavaplugin.so.x86_64
    
  8. Na tela de seleção que aparece, escolha a opção 2 (/usr/java/default/lib/amd64/libnpjp2.so).

  9. Verifique se o plugin foi corretamente configurado no seu navegador acessando o endereço http://www.java.com/en/download/help/testvm.xml.

Fonte: adaptado de http://www.cahilig.net/2011/03/24/how-install-oracle-java-runtime-environment-fedora-14-64-bit

Leonardo Damasceno (http://damasceno.eng.br) é professor da Universidade Federal de Alfenas, no Campus de Poços de Caldas, atuando na área de Engenharia de Meio Ambiente. É entusiasta e usuário de software livre desde 2000.


Veja a relação completa dos artigos de Leonardo Damasceno

 

 

Opinião dos Leitores

João
03 Out 2011, 19:15
Olá amigo, sou novato e encontrei sua dica. Estava indo tudo igual até o comando ./jre... então apareceu a mensagem: "o arquivo /etc/init.d/jexec da instalação de jre-1.6.0_27-fcs.i586 conflita com o arquivo do pacote jdk-2000:1.7.0-fcs.i586". Entendi o erro, mas nao tenho conhecimento para resolver, pode me ajudar?
*Nome:
Email:
Me notifique sobre novos comentários nessa página
Oculte meu email
*Texto:
 
  Para publicar seu comentário, digite o código contido na imagem acima
 


Powered by Scriptsmill Comments Script